インフォメーション

RSS Feeds
2013/02/06  15:20
PHP5.4の提供を開始いたしました

ヘテムルにてPHP5.4の提供を開始しました。14.5%〜24.6%速くなります(当社比)

平素はヘテムルレンタルサーバーをご利用頂きありがとうございます。

本日よりヘテムルにてPHPの最新提供バージョンである
「PHP5.4」の提供を開始いたしました。
「PHP5.4」は従来バージョンのPHP5.3等よりもパフォーマンスが向上しております。

【1】 PHP5.4のパフォーマンス向上について
 ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄
ヘテムルにて従来バージョンであるPHP5.3とPHP5.2と比較する
ベンチマーク(処理速度計測)を実施いたしました。

≪ベンチマーク内容≫
・WordPressで作成したサイトに対し1リクエストあたりの処理にかかった時間
・並列20処理で100リクエストを行うことで実施

≪ベンチマーク結果≫

PHP5.4 ベンチマーク結果

PHP5.2と比較すると24.6%のパフォーマンスアップ!
PHP5.3と比較すると14.5%のパフォーマンスアップ!

上記の結果となり、PHP5.4はパフォーマンスが向上しております。


【2】 PHP5.4からMySQLへの接続ドライバをmysqlndを採用
 ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄
ヘテムルのPHP5.4はMySQLへの接続ドライバを
パフォーマンス向上とメンテナンス性を考慮して
mysqlnd(MySQL native driver for PHP)を採用しました。

≫ PHP−MySQL Native Driver

mysqlndはPHPに特化したMySQL接続ドライバとなります。今後PHP5.4以降はmysqlndが
MySQL向けの標準接続ドライバとなるため採用しております。


【3】 PHP5.4のご利用方法について
 ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄
ヘテムルにてPHP5.4をご利用いただくには、

 1. 拡張子を「.php54」に変更する
 2. [.htaccess]ファイルで指定する

のいずれかの方法にてご利用いただくことができます。
詳細につきましては、下記マニュアルをご覧ください。

≫ マニュアル−PHPのご利用方法について

※CMSやご利用のプラグイン等によってはPHP5.4に対応していない場合がございます。
 PHP5.4をご利用いただく際には動作検証をお願いいたします。



【4】 php.ini設定にPHP5.4を追加しました
 ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄
ヘテムルのコントロールパネルにて設定ができる「php.ini設定」に
「PHP5.4」の項目を追加いたしました。
PHP5.4のphp.ini設定の変更点は以下の通りです。(PHP5.3との比較)

▼選択肢の追加
・error_reporting の項目に「E_ALL & ~E_NOTICE & ~E_STRICT」を追加

▼項目の削除
・magic_quotes_gpc
・safe_mode
・register_globals

≫ マニュアル−php.iniのご利用方法について


【5】 MySQLへの接続の際の注意点
 ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄
2013年2月6日以前に作成されたMySQL5へPHP5.4から接続を
行うためには一度コントロールパネルのデータベースより
パスワードの変更を行なっていただく必要があります。

PHP5.4から既存のMySQLへ接続する場合の設定変更

現在PHP5.4から接続ができないMySQLには「要設定」のリンクが表示されておりますので、
一度パスワードの変更を行なっていただくことでPHP5.4からの接続が可能となります。

※現在設定されているパスワードが8 文字以上 15 文字の場合は同じもので変更いただいても問題ありません。

例)既存のWordPress(PHP5.3)をPHP5.4で動かす場合
1. wp-config.php の下記の記述のパスワードを控える
/** MySQL データベースのパスワード */
define('DB_PASSWORD', '**********');


※パスワードが7文字以下の場合は、8 文字以上 15 文字のパスワードを記述して
ファイルを保存します。


2. ヘテムルのコントロールパネルの「データベース」の「要設定」のリンクよりWordPressで使用しているMySQLのパスワードを1.で控えたパスワードで変更。

3. [.htaccess]ファイルの下記の記述を変更
AddHandler php5.3-script .php

AddHandler php5.4-script .php


4. 動作検証を行う
(プラグインやテーマがPHP5.4に非対応の場合は動作しない可能性がありますので、その場合はPHP5.3に[.htaccess]ファイルを戻してください)

≫ よくある質問−PHP5.4の利用のためデータベースのパスワードを変更したらエラーが発生する

※変更を行った後でもPHP5.3以下のバージョンからも接続ができます。
※MySQLのバージョンが4の場合はPHP5.4からの接続はできません。


ヘテムルでは、今後もお客様への新しい環境提供に努めて参ります。
今後とも、heteml レンタルサーバーをどうぞよろしくお願い致します。



12/12まで
キャンペーン中!

お試しお申し込み

トップヘ戻る