よくある質問

PHPのバージョン変更でサイトがエラーになりました。


PHPについて古いバージョンから新しいバージョンに設定変更いただく場合、
ウェブサイトで用意されているPHPによっては新しいバージョンに未対応のため、
表示や動作がエラーとなる場合がございます。

■ WordPress や EC-CUBE 等の CMS ツールをご利用の場合

WordPress や EC-CUBE 等の CMS ツールについてはサービスの提供元で
ツールのアップデートが提供されております。

古いバージョンの CMS ツールをご利用いただいている場合、
新しいバージョンの PHP に対応していないため、
表示や動作でエラーが発生することも考えられます。

その場合、ご利用いただいている WordPress や EC-CUBE について
最新バージョンへアップデートいただき、ご確認をお願いいたします。


■ 自作いただいた PHP プログラムをご利用の場合

PHP の新しいバージョンでは過去のバージョンでは許可されていた記述などが
セキュリティ上の理由などで非推奨、もしくは利用できない場合がございます。

その場合には表示されたエラー内容を確認いただき、動作可能な記述に
プログラムファイルを修正いただくなどご対応をお願いいたします。


■ PHP プログラム改修がすぐに対応できない場合

すぐにPHPプログラムを動作可能な内容に改修することが難しい場合は
コントロールパネル「PHP設定」より現在選択可能な古いPHPバージョンに
変更いただき、動作をご確認ください。